s/ComputeMaskedBits/ComputeKnownBits/g ?

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

s/ComputeMaskedBits/ComputeKnownBits/g ?

Jay Foad-2
I've always found the name ComputeMaskedBits a bit unintuitive, and
since r154011 it's even worse because there is no masking going on
whatsoever:

http://lists.cs.uiuc.edu/pipermail/llvm-commits/Week-of-Mon-20120402/140280.html

Is there any appetite for a global rename to ComputeKnownBits? Or any
other better names?

Thanks,
Jay.
_______________________________________________
LLVM Developers mailing list
[hidden email]         http://llvm.cs.uiuc.edu
http://lists.cs.uiuc.edu/mailman/listinfo/llvmdev
Reply | Threaded
Open this post in threaded view
|

Re: s/ComputeMaskedBits/ComputeKnownBits/g ?

Rafael Espíndola
On 13 May 2014 14:33, Jay Foad <[hidden email]> wrote:
> I've always found the name ComputeMaskedBits a bit unintuitive, and
> since r154011 it's even worse because there is no masking going on
> whatsoever:
>
> http://lists.cs.uiuc.edu/pipermail/llvm-commits/Week-of-Mon-20120402/140280.html
>
> Is there any appetite for a global rename to ComputeKnownBits? Or any
> other better names?

I like computeKnownBits. Sorry for failing to update the name and
comments with the original change.

Thanks!
Rafael
_______________________________________________
LLVM Developers mailing list
[hidden email]         http://llvm.cs.uiuc.edu
http://lists.cs.uiuc.edu/mailman/listinfo/llvmdev
Reply | Threaded
Open this post in threaded view
|

Re: s/ComputeMaskedBits/ComputeKnownBits/g ?

Duncan P. N. Exon Smith

On 2014-May-13, at 13:27, Rafael Espíndola <[hidden email]> wrote:

> On 13 May 2014 14:33, Jay Foad <[hidden email]> wrote:
>> I've always found the name ComputeMaskedBits a bit unintuitive, and
>> since r154011 it's even worse because there is no masking going on
>> whatsoever:
>>
>> http://lists.cs.uiuc.edu/pipermail/llvm-commits/Week-of-Mon-20120402/140280.html
>>
>> Is there any appetite for a global rename to ComputeKnownBits? Or any
>> other better names?
>
> I like computeKnownBits.

+1.  We should fix the case if we're changing the name anyway.


_______________________________________________
LLVM Developers mailing list
[hidden email]         http://llvm.cs.uiuc.edu
http://lists.cs.uiuc.edu/mailman/listinfo/llvmdev
Reply | Threaded
Open this post in threaded view
|

Re: s/ComputeMaskedBits/ComputeKnownBits/g ?

Chris Lattner-2
In reply to this post by Jay Foad-2

On May 13, 2014, at 11:33 AM, Jay Foad <[hidden email]> wrote:

> I've always found the name ComputeMaskedBits a bit unintuitive, and
> since r154011 it's even worse because there is no masking going on
> whatsoever:
>
> http://lists.cs.uiuc.edu/pipermail/llvm-commits/Week-of-Mon-20120402/140280.html
>
> Is there any appetite for a global rename to ComputeKnownBits? Or any
> other better names?

Makes sense to me.

-Chris

_______________________________________________
LLVM Developers mailing list
[hidden email]         http://llvm.cs.uiuc.edu
http://lists.cs.uiuc.edu/mailman/listinfo/llvmdev
Reply | Threaded
Open this post in threaded view
|

Re: s/ComputeMaskedBits/ComputeKnownBits/g ?

Jay Foad-2
In reply to this post by Rafael Espíndola
On 13 May 2014 21:27, Rafael Espíndola <[hidden email]> wrote:

> On 13 May 2014 14:33, Jay Foad <[hidden email]> wrote:
>> I've always found the name ComputeMaskedBits a bit unintuitive, and
>> since r154011 it's even worse because there is no masking going on
>> whatsoever:
>>
>> http://lists.cs.uiuc.edu/pipermail/llvm-commits/Week-of-Mon-20120402/140280.html
>>
>> Is there any appetite for a global rename to ComputeKnownBits? Or any
>> other better names?
>
> I like computeKnownBits. Sorry for failing to update the name and
> comments with the original change.

Oh yeah, the comments. I've updated them first in r208757.

I'll prepare a patch to rename ComputeMaskedBits to computeKnownBits.
Do I have to worry about any projects outside of the "llvm" svn
module? Or document the name change, in case any out-of-tree code
needs updating?

Thanks,
Jay.

_______________________________________________
LLVM Developers mailing list
[hidden email]         http://llvm.cs.uiuc.edu
http://lists.cs.uiuc.edu/mailman/listinfo/llvmdev
Reply | Threaded
Open this post in threaded view
|

Re: s/ComputeMaskedBits/ComputeKnownBits/g ?

Jay Foad-2
On 14 May 2014 09:10, Jay Foad <[hidden email]> wrote:

> On 13 May 2014 21:27, Rafael Espíndola <[hidden email]> wrote:
>> On 13 May 2014 14:33, Jay Foad <[hidden email]> wrote:
>>> I've always found the name ComputeMaskedBits a bit unintuitive, and
>>> since r154011 it's even worse because there is no masking going on
>>> whatsoever:
>>>
>>> http://lists.cs.uiuc.edu/pipermail/llvm-commits/Week-of-Mon-20120402/140280.html
>>>
>>> Is there any appetite for a global rename to ComputeKnownBits? Or any
>>> other better names?
>>
>> I like computeKnownBits. Sorry for failing to update the name and
>> comments with the original change.
>
> Oh yeah, the comments. I've updated them first in r208757.
>
> I'll prepare a patch to rename ComputeMaskedBits to computeKnownBits.
> Do I have to worry about any projects outside of the "llvm" svn
> module? Or document the name change, in case any out-of-tree code
> needs updating?

N.B. this change affects most targets, since I'll rename their
computeMaskedBitsForTargetNode methods.

Jay.

_______________________________________________
LLVM Developers mailing list
[hidden email]         http://llvm.cs.uiuc.edu
http://lists.cs.uiuc.edu/mailman/listinfo/llvmdev
Reply | Threaded
Open this post in threaded view
|

Re: s/ComputeMaskedBits/ComputeKnownBits/g ?

Rafael Espíndola
In reply to this post by Jay Foad-2
> Oh yeah, the comments. I've updated them first in r208757.

Thanks! Btw, when you rename the function, please also drop the name
from the comments.

> I'll prepare a patch to rename ComputeMaskedBits to computeKnownBits.
> Do I have to worry about any projects outside of the "llvm" svn
> module? Or document the name change, in case any out-of-tree code
> needs updating?

You can send an email to llvmdev, but it should be obvious what
changes need to be done to any out of tree code, so I don't think you
need to.

Thanks,
Rafael
_______________________________________________
LLVM Developers mailing list
[hidden email]         http://llvm.cs.uiuc.edu
http://lists.cs.uiuc.edu/mailman/listinfo/llvmdev
Reply | Threaded
Open this post in threaded view
|

Re: s/ComputeMaskedBits/ComputeKnownBits/g ?

Jay Foad-2
On 14 May 2014 13:59, Rafael Espíndola <[hidden email]> wrote:
> Thanks! Btw, when you rename the function, please also drop the name
> from the comments.

OK. All done in r208811.

Thanks,
Jay.

_______________________________________________
LLVM Developers mailing list
[hidden email]         http://llvm.cs.uiuc.edu
http://lists.cs.uiuc.edu/mailman/listinfo/llvmdev