llvm/tools/lto* rename heads up

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

llvm/tools/lto* rename heads up

Chris Lattner-2
Devang removed the old llvm/tools/lto directory and renamed lto2 ->  
lto.  The end result of this is that 'svn up' may complain.  If you  
get an error about this from svn, just do:

$ rm -rf llvm/tools/lto*
$ svn up llvm/tools

to fix it,

-Chris
_______________________________________________
LLVM Developers mailing list
[hidden email]         http://llvm.cs.uiuc.edu
http://lists.cs.uiuc.edu/mailman/listinfo/llvmdev
Reply | Threaded
Open this post in threaded view
|

Re: llvm/tools/lto* rename heads up

Gabor Greif-2
I have experienced this with a svn 1.5 client but not with 1.4.6.
Did anybody see this with a 1.4.6 (or older) client?

Btw. what is the server version?

Anyway this seems to be a bug in subversion.

Cheers,

    Gabor

PS: http://subversion.tigris.org/servlets/ReadMsg?list=users&msgNo=79361

On Jul 1, 5:27 am, Chris Lattner <[hidden email]> wrote:

> Devang removed the old llvm/tools/lto directory and renamed lto2 ->  
> lto.  The end result of this is that 'svn up' may complain.  If you  
> get an error about this from svn, just do:
>
> $ rm -rf llvm/tools/lto*
> $ svn up llvm/tools
>
> to fix it,
>
> -Chris
> _______________________________________________
> LLVM Developers mailing list
> [hidden email]        http://llvm.cs.uiuc.eduhttp://lists.cs.uiuc.edu/mailman/listinfo/llvmdev

_______________________________________________
LLVM Developers mailing list
[hidden email]         http://llvm.cs.uiuc.edu
http://lists.cs.uiuc.edu/mailman/listinfo/llvmdev
Reply | Threaded
Open this post in threaded view
|

Re: llvm/tools/lto* rename heads up

Matthijs Kooijman
Hi Gabor,

my 1.4.4 didn't complain.

Gr.

Matthijs
_______________________________________________
LLVM Developers mailing list
[hidden email]         http://llvm.cs.uiuc.edu
http://lists.cs.uiuc.edu/mailman/listinfo/llvmdev
Reply | Threaded
Open this post in threaded view
|

Re: llvm/tools/lto* rename heads up

HyperQuantum
In reply to this post by Gabor Greif-2
On Tue, Jul 1, 2008 at 5:27 PM, heisenbug <[hidden email]> wrote:
> I have experienced this with a svn 1.5 client but not with 1.4.6.
> Did anybody see this with a 1.4.6 (or older) client?

Yes, with 1.4.6.


Regards,
Kevin André

_______________________________________________
LLVM Developers mailing list
[hidden email]         http://llvm.cs.uiuc.edu
http://lists.cs.uiuc.edu/mailman/listinfo/llvmdev
Reply | Threaded
Open this post in threaded view
|

Re: llvm/tools/lto* rename heads up

Devang Patel
In reply to this post by Matthijs Kooijman

On Jul 1, 2008, at 9:06 AM, Matthijs Kooijman wrote:

> Hi Gabor,
>
> my 1.4.4 didn't complain.

I did not see any complain with 1.4.4

>
>
> Gr.
>
> Matthijs
> _______________________________________________
> LLVM Developers mailing list
> [hidden email]         http://llvm.cs.uiuc.edu
> http://lists.cs.uiuc.edu/mailman/listinfo/llvmdev

-
Devang



_______________________________________________
LLVM Developers mailing list
[hidden email]         http://llvm.cs.uiuc.edu
http://lists.cs.uiuc.edu/mailman/listinfo/llvmdev
Reply | Threaded
Open this post in threaded view
|

Re: llvm/tools/lto* rename heads up

Gabor Greif-2
In reply to this post by Gabor Greif-2
Mystery resolved. Very old trees with in-tree builds
still had Debug|Release dirs inside tools/lto. These
hindered the renaming process.

see: http://subversion.tigris.org/servlets/ReadMsg?list=users&msgNo=79408

Cheers,

    Gabor

On Jul 1, 5:27 pm, heisenbug <[hidden email]> wrote:

> I have experienced this with a svn 1.5 client but not with 1.4.6.
> Did anybody see this with a 1.4.6 (or older) client?
>
> Btw. what is the server version?
>
> Anyway this seems to be a bug in subversion.
>
> Cheers,
>
>     Gabor
>
> PS:http://subversion.tigris.org/servlets/ReadMsg?list=users&msgNo=79361
>
> On Jul 1, 5:27 am, Chris Lattner <[hidden email]> wrote:
>
> > Devang removed the old llvm/tools/lto directory and renamed lto2 ->  
> > lto.  The end result of this is that 'svn up' may complain.  If you  
> > get an error about this from svn, just do:
>
> > $ rm -rf llvm/tools/lto*
> > $ svn up llvm/tools
>
> > to fix it,
>
> > -Chris
> > _______________________________________________
> > LLVM Developers mailing list
> > [hidden email]        http://llvm.cs.uiuc.eduhttp://lists.cs.uiuc.edu/mailman/listinfo/llvmdev
>
> _______________________________________________
> LLVM Developers mailing list
> [hidden email]        http://llvm.cs.uiuc.eduhttp://lists.cs.uiuc.edu/mailman/listinfo/llvmdev

_______________________________________________
LLVM Developers mailing list
[hidden email]         http://llvm.cs.uiuc.edu
http://lists.cs.uiuc.edu/mailman/listinfo/llvmdev