llvm installation failure

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

llvm installation failure

Ryan M. Lefever
I am trying to make and install a version of llvm that I check out of
cvs last night.  When I configured LLVM, I set the prefix to a directory
inside my home directory.  However, when I did a make install I got the
following errors:

llvm[3]: Installing Debug Bytecode Archive /lib/libc.a
/usr/bin/install: cannot create regular file `/lib/libc.a': Permission
denied
make[3]: *** [/lib/libc.a] Error 1
make[3]: Leaving directory
`/home/performA/users/lefever/testbed-work/llvm-cvs-070325/runtime/GCCLibraries/libc'
make[2]: *** [libc/.makeinstall] Error 2
make[2]: Leaving directory
`/home/performA/users/lefever/testbed-work/llvm-cvs-070325/runtime/GCCLibraries'
make[1]: *** [GCCLibraries/.makeinstall] Error 2
make[1]: Leaving directory
`/home/performA/users/lefever/testbed-work/llvm-cvs-070325/runtime'
make: *** [install] Error 1

It appears to be that lvm is trying to install something into /lib which
is not the prefix that I set. Does anyone know the problem?  Is there
something wrong with one of the makefiles?

Thanks,
Ryan
_______________________________________________
LLVM Developers mailing list
[hidden email]         http://llvm.cs.uiuc.edu
http://lists.cs.uiuc.edu/mailman/listinfo/llvmdev
Reply | Threaded
Open this post in threaded view
|

Re: llvm installation failure

Ryan M. Lefever
I was able to fix the problem by re-configuring, re-making, and
reinstalling llvm.  I must have made a typo somewhere.  It was weird
because everything else installed to the prefix directory, but libc.a
tried to install to /lib.

Ryan M. Lefever wrote:

> I am trying to make and install a version of llvm that I check out of
> cvs last night.  When I configured LLVM, I set the prefix to a directory
> inside my home directory.  However, when I did a make install I got the
> following errors:
>
> llvm[3]: Installing Debug Bytecode Archive /lib/libc.a
> /usr/bin/install: cannot create regular file `/lib/libc.a': Permission
> denied
> make[3]: *** [/lib/libc.a] Error 1
> make[3]: Leaving directory
> `/home/performA/users/lefever/testbed-work/llvm-cvs-070325/runtime/GCCLibraries/libc'
> make[2]: *** [libc/.makeinstall] Error 2
> make[2]: Leaving directory
> `/home/performA/users/lefever/testbed-work/llvm-cvs-070325/runtime/GCCLibraries'
> make[1]: *** [GCCLibraries/.makeinstall] Error 2
> make[1]: Leaving directory
> `/home/performA/users/lefever/testbed-work/llvm-cvs-070325/runtime'
> make: *** [install] Error 1
>
> It appears to be that lvm is trying to install something into /lib which
> is not the prefix that I set. Does anyone know the problem?  Is there
> something wrong with one of the makefiles?
>
> Thanks,
> Ryan
> _______________________________________________
> LLVM Developers mailing list
> [hidden email]         http://llvm.cs.uiuc.edu
> http://lists.cs.uiuc.edu/mailman/listinfo/llvmdev

--
Ryan M. Lefever  [http://www.ews.uiuc.edu/~lefever]
_______________________________________________
LLVM Developers mailing list
[hidden email]         http://llvm.cs.uiuc.edu
http://lists.cs.uiuc.edu/mailman/listinfo/llvmdev