[llvm-dev] LLVM-4.0.1 build problem on Linux

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[llvm-dev] LLVM-4.0.1 build problem on Linux

George Karpenkov via llvm-dev
Hi,

I tried to build LLVM 4.0.1 on a Slackware Linux box with 3 GB of RAM using gcc-7.1.0. Near the end of the build process, I hit the following error:

[ 89%] Linking CXX shared library ../../lib/libLTO.so

collect2: fatal error: ld terminated with signal 9 [Killed]
compilation terminated.
tools/lto/CMakeFiles/LTO.dir/build.make:269: recipe for target 'lib/libLTO.so.4.0.1'
failed
make[2]: *** [lib/libLTO.so.4.0.1] Error 1
make[2]: *** Deleting file 'lib/libLTO.so.4.0.1'
CMakeFiles/Makefile2:13932: recipe for target 'tools/lto/CMakeFiles/LTO.dir/all'
failed
make[1]: *** [tools/lto/CMakeFiles/LTO.dir/all] Error 2
Makefile:149: recipe for target 'all' failed
make: *** [all] Error 2

Can anyone help me with this problem?

Thank you in advance for your time!
Adrian Crisciu

_______________________________________________
LLVM Developers mailing list
[hidden email]
http://lists.llvm.org/cgi-bin/mailman/listinfo/llvm-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [llvm-dev] LLVM-4.0.1 build problem on Linux

George Karpenkov via llvm-dev
Hi,

It seems that your linker was killed during its process, likely because out-of-memory. Here are a few tips:

- Are you building in parallel? One thing would be to reduce the parallelism level.
- By default linux distribution are using the bfd linker, try to switch to gold instead (cmake -DLLVM_USE_LINKER=gold) it is usually a lot more performant.
- Build with optimization and without debug info: cmake -DCMAKE_BUILD_TYPE=Release. 

Hope this'll help!
 
-- 
Mehdi

2017-08-11 9:14 GMT-07:00 Adrian Victor Crisciu via llvm-dev <[hidden email]>:
Hi,

I tried to build LLVM 4.0.1 on a Slackware Linux box with 3 GB of RAM using gcc-7.1.0. Near the end of the build process, I hit the following error:

[ 89%] Linking CXX shared library ../../lib/libLTO.so

collect2: fatal error: ld terminated with signal 9 [Killed]
compilation terminated.
tools/lto/CMakeFiles/LTO.dir/build.make:269: recipe for target 'lib/libLTO.so.4.0.1'
failed
make[2]: *** [lib/libLTO.so.4.0.1] Error 1
make[2]: *** Deleting file 'lib/libLTO.so.4.0.1'
CMakeFiles/Makefile2:13932: recipe for target 'tools/lto/CMakeFiles/LTO.dir/all'
failed
make[1]: *** [tools/lto/CMakeFiles/LTO.dir/all] Error 2
Makefile:149: recipe for target 'all' failed
make: *** [all] Error 2

Can anyone help me with this problem?

Thank you in advance for your time!
Adrian Crisciu

_______________________________________________
LLVM Developers mailing list
[hidden email]
http://lists.llvm.org/cgi-bin/mailman/listinfo/llvm-dev



_______________________________________________
LLVM Developers mailing list
[hidden email]
http://lists.llvm.org/cgi-bin/mailman/listinfo/llvm-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [llvm-dev] LLVM-4.0.1 build problem on Linux

George Karpenkov via llvm-dev
Try increasing swap size if all else fails and you still see maxed memory usage in top, htop.

Just my 2c,
Kevin

On Sat, Aug 12, 2017 at 2:26 PM, Mehdi AMINI via llvm-dev <[hidden email]> wrote:
Hi,

It seems that your linker was killed during its process, likely because out-of-memory. Here are a few tips:

- Are you building in parallel? One thing would be to reduce the parallelism level.
- By default linux distribution are using the bfd linker, try to switch to gold instead (cmake -DLLVM_USE_LINKER=gold) it is usually a lot more performant.
- Build with optimization and without debug info: cmake -DCMAKE_BUILD_TYPE=Release. 

Hope this'll help!
 
-- 
Mehdi

2017-08-11 9:14 GMT-07:00 Adrian Victor Crisciu via llvm-dev <[hidden email]>:
Hi,

I tried to build LLVM 4.0.1 on a Slackware Linux box with 3 GB of RAM using gcc-7.1.0. Near the end of the build process, I hit the following error:

[ 89%] Linking CXX shared library ../../lib/libLTO.so

collect2: fatal error: ld terminated with signal 9 [Killed]
compilation terminated.
tools/lto/CMakeFiles/LTO.dir/build.make:269: recipe for target 'lib/libLTO.so.4.0.1'
failed
make[2]: *** [lib/libLTO.so.4.0.1] Error 1
make[2]: *** Deleting file 'lib/libLTO.so.4.0.1'
CMakeFiles/Makefile2:13932: recipe for target 'tools/lto/CMakeFiles/LTO.dir/all'
failed
make[1]: *** [tools/lto/CMakeFiles/LTO.dir/all] Error 2
Makefile:149: recipe for target 'all' failed
make: *** [all] Error 2

Can anyone help me with this problem?

Thank you in advance for your time!
Adrian Crisciu

_______________________________________________
LLVM Developers mailing list
[hidden email]
http://lists.llvm.org/cgi-bin/mailman/listinfo/llvm-dev



_______________________________________________
LLVM Developers mailing list
[hidden email]
http://lists.llvm.org/cgi-bin/mailman/listinfo/llvm-dev



_______________________________________________
LLVM Developers mailing list
[hidden email]
http://lists.llvm.org/cgi-bin/mailman/listinfo/llvm-dev
Loading...