[llvm-dev] [5.0.0 Release] Release Candidate 2 source and binaries available

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

[llvm-dev] [5.0.0 Release] Release Candidate 2 source and binaries available

Matthias Braun via llvm-dev
Hello everyone,

Source, binaries and docs for LLVM-5.0.0-rc2 are now available at
http://prereleases.llvm.org/5.0.0/#rc2

(I'll add more binaries as they become available.)

Please try it out, run tests, builds your favourite projects and file
bugs about anything that needs to be fixed (including docs!), marking
them blockers of http://llvm.org/pr33849.

Cheers,
Hans
_______________________________________________
LLVM Developers mailing list
[hidden email]
http://lists.llvm.org/cgi-bin/mailman/listinfo/llvm-dev
Reply | Threaded
Open this post in threaded view
|

Re: [llvm-dev] [lldb-dev] [5.0.0 Release] Release Candidate 2 source and binaries available

Matthias Braun via llvm-dev
Hi all,

I've uploaded the mips binaries:

SHA1(clang+llvm-5.0.0-rc2-mipsel-linux-gnu.tar.xz)= 56366fdcaec1ce77d7b481ff74f6d4132b3219d7
SHA1(clang+llvm-5.0.0-rc2-mips-linux-gnu.tar.xz)= 8b66db0b4fe3e5d288ee6ac32621bdfdbc9e3233
SHA1(clang+llvm-5.0.0-rc2-x86_64-linux-gnu-debian8.tar.xz)= 5dc4589936465320246837225ac400b7a19893c8

I'm seeing the same set of failures that I saw from rc1 (http://lists.llvm.org/pipermail/llvm-dev/2017-August/116031.html)
without the failures from LLVM, as I've identified that as a format(..) issue that MIPS managed to tickle. I've smoke-tested the
release branch of clang @ 310902 with llvm @ r311064, and the reported failures from clang are gone.

I have filed PR32433 and PR32434 to address the remaining failures.

The test-suite for mips and mipsel appears clean.

x86_64-linux-gnu-debian8 appears clean.

Thanks,
Simon
________________________________________
From: lldb-dev [[hidden email]] on behalf of Hans Wennborg via lldb-dev [[hidden email]]
Sent: 14 August 2017 23:30
To: llvm-dev; cfe-dev; LLDB Dev; openmp-dev ([hidden email]); Release-testers
Subject: [lldb-dev] [5.0.0 Release] Release Candidate 2 source and binaries     available

Hello everyone,

Source, binaries and docs for LLVM-5.0.0-rc2 are now available at
http://prereleases.llvm.org/5.0.0/#rc2

(I'll add more binaries as they become available.)

Please try it out, run tests, builds your favourite projects and file
bugs about anything that needs to be fixed (including docs!), marking
them blockers of http://llvm.org/pr33849.

Cheers,
Hans
_______________________________________________
lldb-dev mailing list
[hidden email]
http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-dev
_______________________________________________
LLVM Developers mailing list
[hidden email]
http://lists.llvm.org/cgi-bin/mailman/listinfo/llvm-dev
Reply | Threaded
Open this post in threaded view
|

Re: [llvm-dev] [lldb-dev] [5.0.0 Release] Release Candidate 2 source and binaries available

Matthias Braun via llvm-dev
Thanks! I've added the binaries to the pre-release page.

On Fri, Aug 18, 2017 at 8:44 AM, Simon Dardis <[hidden email]> wrote:

> Hi all,
>
> I've uploaded the mips binaries:
>
> SHA1(clang+llvm-5.0.0-rc2-mipsel-linux-gnu.tar.xz)= 56366fdcaec1ce77d7b481ff74f6d4132b3219d7
> SHA1(clang+llvm-5.0.0-rc2-mips-linux-gnu.tar.xz)= 8b66db0b4fe3e5d288ee6ac32621bdfdbc9e3233
> SHA1(clang+llvm-5.0.0-rc2-x86_64-linux-gnu-debian8.tar.xz)= 5dc4589936465320246837225ac400b7a19893c8
>
> I'm seeing the same set of failures that I saw from rc1 (http://lists.llvm.org/pipermail/llvm-dev/2017-August/116031.html)
> without the failures from LLVM, as I've identified that as a format(..) issue that MIPS managed to tickle. I've smoke-tested the
> release branch of clang @ 310902 with llvm @ r311064, and the reported failures from clang are gone.
>
> I have filed PR32433 and PR32434 to address the remaining failures.
>
> The test-suite for mips and mipsel appears clean.
>
> x86_64-linux-gnu-debian8 appears clean.
>
> Thanks,
> Simon
> ________________________________________
> From: lldb-dev [[hidden email]] on behalf of Hans Wennborg via lldb-dev [[hidden email]]
> Sent: 14 August 2017 23:30
> To: llvm-dev; cfe-dev; LLDB Dev; openmp-dev ([hidden email]); Release-testers
> Subject: [lldb-dev] [5.0.0 Release] Release Candidate 2 source and binaries     available
>
> Hello everyone,
>
> Source, binaries and docs for LLVM-5.0.0-rc2 are now available at
> http://prereleases.llvm.org/5.0.0/#rc2
>
> (I'll add more binaries as they become available.)
>
> Please try it out, run tests, builds your favourite projects and file
> bugs about anything that needs to be fixed (including docs!), marking
> them blockers of http://llvm.org/pr33849.
>
> Cheers,
> Hans
> _______________________________________________
> lldb-dev mailing list
> [hidden email]
> http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-dev
_______________________________________________
LLVM Developers mailing list
[hidden email]
http://lists.llvm.org/cgi-bin/mailman/listinfo/llvm-dev
Reply | Threaded
Open this post in threaded view
|

Re: [llvm-dev] [5.0.0 Release] Release Candidate 2 source and binaries available

Matthias Braun via llvm-dev
In reply to this post by Matthias Braun via llvm-dev
Is there something wrong with the .deb packages? Identical commands work for 4.0.

$ sudo sh -c 'echo "deb http://apt.llvm.org/trusty/ llvm-toolchain-trusty-5.0 main" >> /etc/apt/sources.list'
$ wget -O - <a href="http://apt.llvm.org/llvm-snapshot.gpg.key|sudo">http://apt.llvm.org/llvm-snapshot.gpg.key|sudo apt-key add -
$ sudo apt-get update -q
$ sudo apt-get remove -y llvm-*
$ sudo rm -rf /usr/local/*
$ sudo apt-get install -y clang-5.0 libclang-5.0 libclang-5.0-dev llvm-5.0 llvm-5.0-dev liblld-5.0 liblld-5.0-dev cmake
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'libclang-5.0-dev' for regex 'libclang-5.0'
cmake is already the newest version (3.2.2-2~ubuntu14.04.1~ppa1).
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
 clang-5.0 : Depends: libclang1-5.0 (= 1:5.0~svn310902-1~exp1) but it is not going to be installed
             Depends: libllvm5.0 (>= 1:5.0~svn298832-1~) but it is not going to be installed
             Depends: libstdc++6 (>= 6) but 4.8.4-2ubuntu1~14.04.3 is to be installed
             Depends: libstdc++-6-dev but it is not installable
             Depends: libgcc-6-dev but it is not installable
             Depends: libobjc-6-dev but it is not installable
             Depends: libclang-common-5.0-dev (= 1:5.0~svn310902-1~exp1) but it is not going to be installed
 libclang-5.0-dev : Depends: libstdc++-6-dev but it is not installable
                    Depends: libgcc-6-dev but it is not installable
                    Depends: libobjc-6-dev but it is not installable
                    Depends: libclang1-5.0 (= 1:5.0~svn310902-1~exp1) but it is not going to be installed
                    Depends: libclang-common-5.0-dev (= 1:5.0~svn310902-1~exp1) but it is not going to be installed
 liblld-5.0 : Depends: libllvm5.0 (= 1:5.0~svn310902-1~exp1) but it is not going to be installed
 liblld-5.0-dev : Depends: lld-5.0 (= 1:5.0~svn310902-1~exp1) but it is not going to be installed
 llvm-5.0 : Depends: llvm-5.0-runtime (= 1:5.0~svn310902-1~exp1) but it is not going to be installed
            Depends: libllvm5.0 (>= 1:5.0~svn298832-1~) but it is not going to be installed
            Depends: libstdc++6 (>= 5) but 4.8.4-2ubuntu1~14.04.3 is to be installed
 llvm-5.0-dev : Depends: libllvm5.0 (= 1:5.0~svn310902-1~exp1) but it is not going to be installed
                Depends: libstdc++6 (>= 5) but 4.8.4-2ubuntu1~14.04.3 is to be installed
E: Unable to correct problems, you have held broken packages.
The command "sudo apt-get install -y clang-5.0 libclang-5.0 libclang-5.0-dev llvm-5.0 llvm-5.0-dev liblld-5.0 liblld-5.0-dev cmake" failed and exited with 100 during .

On Mon, Aug 14, 2017 at 6:30 PM, Hans Wennborg via llvm-dev <[hidden email]> wrote:
Hello everyone,

Source, binaries and docs for LLVM-5.0.0-rc2 are now available at
http://prereleases.llvm.org/5.0.0/#rc2

(I'll add more binaries as they become available.)

Please try it out, run tests, builds your favourite projects and file
bugs about anything that needs to be fixed (including docs!), marking
them blockers of http://llvm.org/pr33849.

Cheers,
Hans
_______________________________________________
LLVM Developers mailing list
[hidden email]
http://lists.llvm.org/cgi-bin/mailman/listinfo/llvm-dev


_______________________________________________
LLVM Developers mailing list
[hidden email]
http://lists.llvm.org/cgi-bin/mailman/listinfo/llvm-dev
Reply | Threaded
Open this post in threaded view
|

Re: [llvm-dev] [Release-testers] [5.0.0 Release] Release Candidate 2 source and binaries available

Matthias Braun via llvm-dev
Hello,

This is because a new libstdc++ is necessary, it is coming with gcc-4.9 backports.
I updated the doc, sorry about that!

Adding
or
sudo add-apt-repository ppa:ubuntu-toolchain-r/test

Cheers,
Sylvestre


Le 20/08/2017 à 04:00, Andrew Kelley via Release-testers a écrit :
Is there something wrong with the .deb packages? Identical commands work for 4.0.

$ sudo sh -c 'echo "deb http://apt.llvm.org/trusty/ llvm-toolchain-trusty-5.0 main" >> /etc/apt/sources.list'
$ wget -O - <a href="http://apt.llvm.org/llvm-snapshot.gpg.key|sudo" moz-do-not-send="true">http://apt.llvm.org/llvm-snapshot.gpg.key|sudo apt-key add -
$ sudo apt-get update -q
$ sudo apt-get remove -y llvm-*
$ sudo rm -rf /usr/local/*
$ sudo apt-get install -y clang-5.0 libclang-5.0 libclang-5.0-dev llvm-5.0 llvm-5.0-dev liblld-5.0 liblld-5.0-dev cmake
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'libclang-5.0-dev' for regex 'libclang-5.0'
cmake is already the newest version (3.2.2-2~ubuntu14.04.1~ppa1).
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
 clang-5.0 : Depends: libclang1-5.0 (= 1:5.0~svn310902-1~exp1) but it is not going to be installed
             Depends: libllvm5.0 (>= 1:5.0~svn298832-1~) but it is not going to be installed
             Depends: libstdc++6 (>= 6) but 4.8.4-2ubuntu1~14.04.3 is to be installed
             Depends: libstdc++-6-dev but it is not installable
             Depends: libgcc-6-dev but it is not installable
             Depends: libobjc-6-dev but it is not installable
             Depends: libclang-common-5.0-dev (= 1:5.0~svn310902-1~exp1) but it is not going to be installed
 libclang-5.0-dev : Depends: libstdc++-6-dev but it is not installable
                    Depends: libgcc-6-dev but it is not installable
                    Depends: libobjc-6-dev but it is not installable
                    Depends: libclang1-5.0 (= 1:5.0~svn310902-1~exp1) but it is not going to be installed
                    Depends: libclang-common-5.0-dev (= 1:5.0~svn310902-1~exp1) but it is not going to be installed
 liblld-5.0 : Depends: libllvm5.0 (= 1:5.0~svn310902-1~exp1) but it is not going to be installed
 liblld-5.0-dev : Depends: lld-5.0 (= 1:5.0~svn310902-1~exp1) but it is not going to be installed
 llvm-5.0 : Depends: llvm-5.0-runtime (= 1:5.0~svn310902-1~exp1) but it is not going to be installed
            Depends: libllvm5.0 (>= 1:5.0~svn298832-1~) but it is not going to be installed
            Depends: libstdc++6 (>= 5) but 4.8.4-2ubuntu1~14.04.3 is to be installed
 llvm-5.0-dev : Depends: libllvm5.0 (= 1:5.0~svn310902-1~exp1) but it is not going to be installed
                Depends: libstdc++6 (>= 5) but 4.8.4-2ubuntu1~14.04.3 is to be installed
E: Unable to correct problems, you have held broken packages.
The command "sudo apt-get install -y clang-5.0 libclang-5.0 libclang-5.0-dev llvm-5.0 llvm-5.0-dev liblld-5.0 liblld-5.0-dev cmake" failed and exited with 100 during .

On Mon, Aug 14, 2017 at 6:30 PM, Hans Wennborg via llvm-dev <[hidden email]> wrote:
Hello everyone,

Source, binaries and docs for LLVM-5.0.0-rc2 are now available at
http://prereleases.llvm.org/5.0.0/#rc2

(I'll add more binaries as they become available.)

Please try it out, run tests, builds your favourite projects and file
bugs about anything that needs to be fixed (including docs!), marking
them blockers of http://llvm.org/pr33849.

Cheers,
Hans
_______________________________________________
LLVM Developers mailing list
[hidden email]
http://lists.llvm.org/cgi-bin/mailman/listinfo/llvm-dev


_______________________________________________
Release-testers mailing list
[hidden email]
http://lists.llvm.org/cgi-bin/mailman/listinfo/release-testers

_______________________________________________
LLVM Developers mailing list
[hidden email]
http://lists.llvm.org/cgi-bin/mailman/listinfo/llvm-dev
Reply | Threaded
Open this post in threaded view
|

Re: [llvm-dev] [Release-testers] [5.0.0 Release] Release Candidate 2 source and binaries available

Matthias Braun via llvm-dev
Thank you, that worked.

On Sun, Aug 20, 2017 at 4:17 AM, Sylvestre Ledru <[hidden email]> wrote:
Hello,

This is because a new libstdc++ is necessary, it is coming with gcc-4.9 backports.
I updated the doc, sorry about that!

Adding
or
sudo add-apt-repository ppa:ubuntu-toolchain-r/test

Cheers,
Sylvestre


Le 20/08/2017 à 04:00, Andrew Kelley via Release-testers a écrit :
Is there something wrong with the .deb packages? Identical commands work for 4.0.

$ sudo sh -c 'echo "deb http://apt.llvm.org/trusty/ llvm-toolchain-trusty-5.0 main" >> /etc/apt/sources.list'
$ sudo apt-get update -q
$ sudo apt-get remove -y llvm-*
$ sudo rm -rf /usr/local/*
$ sudo apt-get install -y clang-5.0 libclang-5.0 libclang-5.0-dev llvm-5.0 llvm-5.0-dev liblld-5.0 liblld-5.0-dev cmake
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'libclang-5.0-dev' for regex 'libclang-5.0'
cmake is already the newest version (3.2.2-2~ubuntu14.04.1~ppa1).
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
 clang-5.0 : Depends: libclang1-5.0 (= 1:5.0~svn310902-1~exp1) but it is not going to be installed
             Depends: libllvm5.0 (>= 1:5.0~svn298832-1~) but it is not going to be installed
             Depends: libstdc++6 (>= 6) but 4.8.4-2ubuntu1~14.04.3 is to be installed
             Depends: libstdc++-6-dev but it is not installable
             Depends: libgcc-6-dev but it is not installable
             Depends: libobjc-6-dev but it is not installable
             Depends: libclang-common-5.0-dev (= 1:5.0~svn310902-1~exp1) but it is not going to be installed
 libclang-5.0-dev : Depends: libstdc++-6-dev but it is not installable
                    Depends: libgcc-6-dev but it is not installable
                    Depends: libobjc-6-dev but it is not installable
                    Depends: libclang1-5.0 (= 1:5.0~svn310902-1~exp1) but it is not going to be installed
                    Depends: libclang-common-5.0-dev (= 1:5.0~svn310902-1~exp1) but it is not going to be installed
 liblld-5.0 : Depends: libllvm5.0 (= 1:5.0~svn310902-1~exp1) but it is not going to be installed
 liblld-5.0-dev : Depends: lld-5.0 (= 1:5.0~svn310902-1~exp1) but it is not going to be installed
 llvm-5.0 : Depends: llvm-5.0-runtime (= 1:5.0~svn310902-1~exp1) but it is not going to be installed
            Depends: libllvm5.0 (>= 1:5.0~svn298832-1~) but it is not going to be installed
            Depends: libstdc++6 (>= 5) but 4.8.4-2ubuntu1~14.04.3 is to be installed
 llvm-5.0-dev : Depends: libllvm5.0 (= 1:5.0~svn310902-1~exp1) but it is not going to be installed
                Depends: libstdc++6 (>= 5) but 4.8.4-2ubuntu1~14.04.3 is to be installed
E: Unable to correct problems, you have held broken packages.
The command "sudo apt-get install -y clang-5.0 libclang-5.0 libclang-5.0-dev llvm-5.0 llvm-5.0-dev liblld-5.0 liblld-5.0-dev cmake" failed and exited with 100 during .

On Mon, Aug 14, 2017 at 6:30 PM, Hans Wennborg via llvm-dev <[hidden email]> wrote:
Hello everyone,

Source, binaries and docs for LLVM-5.0.0-rc2 are now available at
http://prereleases.llvm.org/5.0.0/#rc2

(I'll add more binaries as they become available.)

Please try it out, run tests, builds your favourite projects and file
bugs about anything that needs to be fixed (including docs!), marking
them blockers of http://llvm.org/pr33849.

Cheers,
Hans
_______________________________________________
LLVM Developers mailing list
[hidden email]
http://lists.llvm.org/cgi-bin/mailman/listinfo/llvm-dev


_______________________________________________
Release-testers mailing list
[hidden email]
http://lists.llvm.org/cgi-bin/mailman/listinfo/release-testers


_______________________________________________
LLVM Developers mailing list
[hidden email]
http://lists.llvm.org/cgi-bin/mailman/listinfo/llvm-dev