help!

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

help!

shding
Hi,
   I have some problems when I use this command: gcc hello.s -o
hello.native(for example) to assembly the native language to a program.
I always got a error message like this :
"gccas: hello.s:3: parse error, unexpected $undefined.
hello.s:3:  while reading token: '.' "
   I don't know what's wrong here. By the way, when I learned llvm at the
first time, I followed the simple example on web of "Getting Started
with  LLVM System", everything is ok, I didn't see such an error.
   It maybe a very silly question to you, but could anyone give me some
help if you've had the same experience?

--
Shuhan

_______________________________________________
LLVM Developers mailing list
[hidden email]         http://llvm.cs.uiuc.edu
http://mail.cs.uiuc.edu/mailman/listinfo/llvmdev
Reply | Threaded
Open this post in threaded view
|

Re: help!

shding
   I've found the reason. This is really a silly question. Because I set
llvm-gcc/bin as a gloval path, there's a gcc in this directory which
replace the original gcc.
   Sorry to bother you.

> Hi,
>    I have some problems when I use this command: gcc hello.s -o
> hello.native(for example) to assembly the native language to a program.
> I always got a error message like this :
> "gccas: hello.s:3: parse error, unexpected $undefined.
> hello.s:3:  while reading token: '.' "
>    I don't know what's wrong here. By the way, when I learned llvm at the
> first time, I followed the simple example on web of "Getting Started
> with  LLVM System", everything is ok, I didn't see such an error.
>    It maybe a very silly question to you, but could anyone give me some
> help if you've had the same experience?
>
> --
> Shuhan
>
> _______________________________________________
> LLVM Developers mailing list
> [hidden email]         http://llvm.cs.uiuc.edu
> http://mail.cs.uiuc.edu/mailman/listinfo/llvmdev
>


--
Shuhan

_______________________________________________
LLVM Developers mailing list
[hidden email]         http://llvm.cs.uiuc.edu
http://mail.cs.uiuc.edu/mailman/listinfo/llvmdev
Reply | Threaded
Open this post in threaded view
|

Re: help!

Reid Spencer
In reply to this post by shding
Hello,

I'm not completely sure what your situation is, so here's a few
questions that might help you resolve the situation or might help me
understand what's going on?

1. Are you running gcc or llvm-gcc?
2. The "unexpected $undefined" message usually happens when the LLVM
assembly is syntactically invalid. This shouldn't happen between llvm-
gcc and gccas. So, I'm wondering if hello.s is *native* assembly or LLVM
assembly. Typically we use the .ll extension for LLVM assembly.
3. Could you append your inputs and outputs so we can see what's
happening?

Reid

On Mon, 2005-05-30 at 11:53 -0400, [hidden email] wrote:

> Hi,
>    I have some problems when I use this command: gcc hello.s -o
> hello.native(for example) to assembly the native language to a program.
> I always got a error message like this :
> "gccas: hello.s:3: parse error, unexpected $undefined.
> hello.s:3:  while reading token: '.' "
>    I don't know what's wrong here. By the way, when I learned llvm at the
> first time, I followed the simple example on web of "Getting Started
> with  LLVM System", everything is ok, I didn't see such an error.
>    It maybe a very silly question to you, but could anyone give me some
> help if you've had the same experience?
>

_______________________________________________
LLVM Developers mailing list
[hidden email]         http://llvm.cs.uiuc.edu
http://mail.cs.uiuc.edu/mailman/listinfo/llvmdev

signature.asc (196 bytes) Download Attachment