Trying to compile frontend 4.0 fails on cygwin

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Trying to compile frontend 4.0 fails on cygwin

Seth Copen Goldstein
I sent an earlier email about failing to compile 4.2, I have since tried
4.0 and I get a configure error during make.  

I am running on windows XP SP2
Cygwin is (as reported by uname -a): CYGWIN_NT-5.1 pad7
1.5.25(0.156/4/2) 2007-12-14 19:21 i686 Cygwin
Gcc is: gcc (GCC) 3.4.4 (cygming special, gdc 0.12, using dmd 0.125)
I ran configure, then make.  Make dies with:

checking whether the C compiler works... configure: error: cannot run C
compiled programs.
If you meant to cross compile, use `--host'.

The config.log contains:

This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

configure:595: checking host system type
configure:616: checking target system type
configure:634: checking build system type
configure:689: checking for a BSD compatible install
configure:742: checking whether ln works
configure:766: checking whether ln -s works
configure:1820: checking for gcc
configure:1933: checking whether the C compiler (gcc  ) works
configure:1949: gcc -o conftest    conftest.c  1>&5
configure:1975: checking whether the C compiler (gcc  ) is a
cross-compiler
configure:1980: checking whether we are using GNU C
configure:1989: gcc -E conftest.c
configure:2008: checking whether gcc accepts -g
configure:2075: checking for gnatbind
configure:2140: checking whether compiler driver understands Ada
configure:2172: checking how to compare bootstrapped objects
configure:2270: checking for correct version of gmp.h
configure:2283: gcc -c -g -O2   conftest.c 1>&5
configure:2273:17: gmp.h: No such file or directory
configure: In function `main':
configure:2277: error: `choke' undeclared (first use in this function)
configure:2277: error: (Each undeclared identifier is reported only once
configure:2277: error: for each function it appears in.)
configure:2277: error: parse error before "me"
configure: failed program was:
#line 2272 "configure"
#include "confdefs.h"
#include "gmp.h"
int main() {

#if __GNU_MP_VERSION < 3
choke me
#endif

; return 0; }
configure:2796: checking for bison
configure:2831: checking for bison
configure:2866: checking for gm4
configure:2866: checking for gnum4
configure:2866: checking for m4
configure:2901: checking for flex
configure:2936: checking for flex
configure:2971: checking for makeinfo
configure:3618: checking for i686-pc-cygwin-ar
configure:3651: checking for ar
configure:3690: checking for i686-pc-cygwin-as
configure:3723: checking for as
configure:3762: checking for i686-pc-cygwin-dlltool
configure:3795: checking for dlltool
configure:3834: checking for i686-pc-cygwin-ld
configure:3906: checking for i686-pc-cygwin-nm
configure:3939: checking for nm
configure:3978: checking for i686-pc-cygwin-ranlib
configure:4011: checking for ranlib
configure:4050: checking for i686-pc-cygwin-windres
configure:4083: checking for windres
configure:4122: checking for i686-pc-cygwin-objcopy
configure:4155: checking for objcopy
configure:4194: checking for i686-pc-cygwin-objdump
configure:4227: checking for objdump
configure:4273: checking for i686-pc-cygwin-ar
configure:4306: checking for ar
configure:4345: checking for i686-pc-cygwin-as
configure:4378: checking for as
configure:4417: checking for i686-pc-cygwin-dlltool
configure:4450: checking for dlltool
configure:4489: checking for i686-pc-cygwin-ld
configure:4522: checking for ld
configure:4561: checking for i686-pc-cygwin-lipo
configure:4594: checking for lipo
configure:4633: checking for i686-pc-cygwin-nm
configure:4666: checking for nm
configure:4705: checking for i686-pc-cygwin-ranlib
configure:4738: checking for ranlib
configure:4777: checking for i686-pc-cygwin-strip
configure:4810: checking for strip
configure:4849: checking for i686-pc-cygwin-windres
configure:4882: checking for windres
configure:4973: checking whether to enable maintainer-specific portions
of Makefiles
configure:5020: checking if symbolic links between directories work

-seth

---------------
[hidden email]                    7122 Wean Hall
www.cs.cmu.edu/~seth               School of Computer Science
phone: 412-268-3828                Carnegie Mellon University
fax:   412-268-4801                Pittsburgh, PA 15213



_______________________________________________
LLVM Developers mailing list
[hidden email]         http://llvm.cs.uiuc.edu
http://lists.cs.uiuc.edu/mailman/listinfo/llvmdev
Reply | Threaded
Open this post in threaded view
|

Re: Trying to compile frontend 4.0 fails on cygwin

Anton Korobeynikov
Hello, Seth

> checking whether the C compiler works... configure: error: cannot run C
> compiled programs.
This usually means, that simple program like:

int main(void) {
  return 0;
}

failed either to be compiled or to run.

> The config.log contains:
The gcc build system is complicated - 'configure' executes just top
level configure and nothing more. 'make' itself executes different
configures in subdirectories, so most probably it was generated by one
of them and you have to check config.log in some subdirectory.

> configure:2273:17: gmp.h: No such file or directory
Well, 4.0 doesn't require gmp to be present, as 4.2, so one can treat
this as warning.

--
WBR, Anton Korobeynikov
_______________________________________________
LLVM Developers mailing list
[hidden email]         http://llvm.cs.uiuc.edu
http://lists.cs.uiuc.edu/mailman/listinfo/llvmdev