LLVM on Mac OS X Tiger 10.4.11

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

LLVM on Mac OS X Tiger 10.4.11

Bijoy Thomas-2
Hello,

   I apologize if this has been covered before but has anyone
successfully built llvm on Mac OS X Tiger (10.4.11)? I upgraded to
Xcode 2.4.1 and got the binaries for the llvm-gcc frontend and the
source for llvm. I built llvm but realized that the frontend binaries
required libiconv version 7.0.0. but the version on Tiger is 5.0.0.
Trying to build the frontend from source gives me a bunch of errors.

My configure command is

$../configure --prefix=`pwd`/../install/ --build=$TRIPLE
--host=$TRIPLE --target=$TRIPLE
--with-gxx-include-dir=/usr/include/c++/4.0.0 --program-prefix=llvm-
--enable-languages=c -enable-llvm=/usr/local/llvm-2.5

I'm running this from an 'obj' dir under the llvm-gcc source tree.

The error is get is that SIZEOF_INT and SIZEOF_LONG are not defined.

Anything wrong with what i'm doing or my configure command?

Thanks,
Bijoy.

--
"The task AHEAD of you is never as great as the POWER behind you"
_______________________________________________
LLVM Developers mailing list
[hidden email]         http://llvm.cs.uiuc.edu
http://lists.cs.uiuc.edu/mailman/listinfo/llvmdev
Reply | Threaded
Open this post in threaded view
|

Re: LLVM on Mac OS X Tiger 10.4.11

Bijoy Thomas-2
Looks like I was a little too ambitious in getting version LLVM-2.5 to
build on Mac OS X Tiger which uses gcc 4.0.1. LLVM -2.2 built fine.

I did get the LLVM-2.5 tree to build but it was the gcc front-end part
of it that failed. If anyone has built the both parts of version 2.5
on Tiger please let me know.

Thanks,
Bijoy.

On Mon, Mar 30, 2009 at 11:40 PM, Bijoy Thomas <[hidden email]> wrote:

> Hello,
>
>   I apologize if this has been covered before but has anyone
> successfully built llvm on Mac OS X Tiger (10.4.11)? I upgraded to
> Xcode 2.4.1 and got the binaries for the llvm-gcc frontend and the
> source for llvm. I built llvm but realized that the frontend binaries
> required libiconv version 7.0.0. but the version on Tiger is 5.0.0.
> Trying to build the frontend from source gives me a bunch of errors.
>
> My configure command is
>
> $../configure --prefix=`pwd`/../install/ --build=$TRIPLE
> --host=$TRIPLE --target=$TRIPLE
> --with-gxx-include-dir=/usr/include/c++/4.0.0 --program-prefix=llvm-
> --enable-languages=c -enable-llvm=/usr/local/llvm-2.5
>
> I'm running this from an 'obj' dir under the llvm-gcc source tree.
>
> The error is get is that SIZEOF_INT and SIZEOF_LONG are not defined.
>
> Anything wrong with what i'm doing or my configure command?
>
> Thanks,
> Bijoy.
>
> --
> "The task AHEAD of you is never as great as the POWER behind you"
>



--
"The task AHEAD of you is never as great as the POWER behind you"

_______________________________________________
LLVM Developers mailing list
[hidden email]         http://llvm.cs.uiuc.edu
http://lists.cs.uiuc.edu/mailman/listinfo/llvmdev
Reply | Threaded
Open this post in threaded view
|

Re: LLVM on Mac OS X Tiger 10.4.11

Tanya Lattner-2

> Looks like I was a little too ambitious in getting version LLVM-2.5 to
> build on Mac OS X Tiger which uses gcc 4.0.1. LLVM -2.2 built fine.

LLVM 2.3 was the last release that was qualified on Tiger. We need members
from the community to step up an maintain LLVM and llvm-gcc on Tiger. I no
longer have a Tiger machine when doing releases.

Thanks,
Tanya

>
> I did get the LLVM-2.5 tree to build but it was the gcc front-end part
> of it that failed. If anyone has built the both parts of version 2.5
> on Tiger please let me know.
>
> Thanks,
> Bijoy.
>
> On Mon, Mar 30, 2009 at 11:40 PM, Bijoy Thomas <[hidden email]> wrote:
>> Hello,
>>
>>   I apologize if this has been covered before but has anyone
>> successfully built llvm on Mac OS X Tiger (10.4.11)? I upgraded to
>> Xcode 2.4.1 and got the binaries for the llvm-gcc frontend and the
>> source for llvm. I built llvm but realized that the frontend binaries
>> required libiconv version 7.0.0. but the version on Tiger is 5.0.0.
>> Trying to build the frontend from source gives me a bunch of errors.
>>
>> My configure command is
>>
>> $../configure --prefix=`pwd`/../install/ --build=$TRIPLE
>> --host=$TRIPLE --target=$TRIPLE
>> --with-gxx-include-dir=/usr/include/c++/4.0.0 --program-prefix=llvm-
>> --enable-languages=c -enable-llvm=/usr/local/llvm-2.5
>>
>> I'm running this from an 'obj' dir under the llvm-gcc source tree.
>>
>> The error is get is that SIZEOF_INT and SIZEOF_LONG are not defined.
>>
>> Anything wrong with what i'm doing or my configure command?
>>
>> Thanks,
>> Bijoy.
>>
>> --
>> "The task AHEAD of you is never as great as the POWER behind you"
>>
>
>
>
> --
> "The task AHEAD of you is never as great as the POWER behind you"
>
> _______________________________________________
> LLVM Developers mailing list
> [hidden email]         http://llvm.cs.uiuc.edu
> http://lists.cs.uiuc.edu/mailman/listinfo/llvmdev
>
_______________________________________________
LLVM Developers mailing list
[hidden email]         http://llvm.cs.uiuc.edu
http://lists.cs.uiuc.edu/mailman/listinfo/llvmdev