LLVM/.Clang: 'make install'

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

LLVM/.Clang: 'make install'

John Smith-35
Hi,


I just compiled llvm/clang from source on my fedora linux system as
specified on the website, but running 'make' and 'make install' does
not seem to result in a 'functioning' installation ?

I mean, neither 'clang' or 'scan-build' seem to be found ?

Are there any other actions I need to perform on my linux system in
order to complete the installation ? Or am I just doing something
wrong here ?


Thanks in advance,


Regards,


John Smith.
_______________________________________________
LLVM Developers mailing list
[hidden email]         http://llvm.cs.uiuc.edu
http://lists.cs.uiuc.edu/mailman/listinfo/llvmdev
Reply | Threaded
Open this post in threaded view
|

Re: [cfe-dev] LLVM/.Clang: 'make install'

John Myers-5
Hi,

make install works for me on Ubuntu.
Does the output of make install show that it was successful?
Was it setup to be installed in a PATH location of Fedora?

--John

_______________________________________________
LLVM Developers mailing list
[hidden email]         http://llvm.cs.uiuc.edu
http://lists.cs.uiuc.edu/mailman/listinfo/llvmdev
Reply | Threaded
Open this post in threaded view
|

Re: [cfe-dev] LLVM/.Clang: 'make install'

John Smith-35
Hi,


Sorry, but I cant seem to repeat the issue anymore. 'make install'
works fine now. I have no idea what went wrong the first time.

Thanks for the effort, and sorry to have bothered you with this.



On Mon, Apr 11, 2011 at 2:25 PM, John Myers <[hidden email]> wrote:
> Hi,
>
> make install works for me on Ubuntu.
> Does the output of make install show that it was successful?
> Was it setup to be installed in a PATH location of Fedora?
>
> --John
>
_______________________________________________
LLVM Developers mailing list
[hidden email]         http://llvm.cs.uiuc.edu
http://lists.cs.uiuc.edu/mailman/listinfo/llvmdev
Reply | Threaded
Open this post in threaded view
|

Re: [cfe-dev] LLVM/.Clang: 'make install'

Ted Kremenek-2
Hi John,

Note that scan-build should not be included in a 'make install'.  It's not considered part of the compiler itself.

On Apr 11, 2011, at 10:04 AM, John Smith wrote:

> Hi,
>
>
> Sorry, but I cant seem to repeat the issue anymore. 'make install'
> works fine now. I have no idea what went wrong the first time.
>
> Thanks for the effort, and sorry to have bothered you with this.
>
>
>
> On Mon, Apr 11, 2011 at 2:25 PM, John Myers <[hidden email]> wrote:
>> Hi,
>>
>> make install works for me on Ubuntu.
>> Does the output of make install show that it was successful?
>> Was it setup to be installed in a PATH location of Fedora?
>>
>> --John
>>
> _______________________________________________
> LLVM Developers mailing list
> [hidden email]         http://llvm.cs.uiuc.edu
> http://lists.cs.uiuc.edu/mailman/listinfo/llvmdev

_______________________________________________
LLVM Developers mailing list
[hidden email]         http://llvm.cs.uiuc.edu
http://lists.cs.uiuc.edu/mailman/listinfo/llvmdev