Compilation problems

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Compilation problems

Ferad Zyulkyarov
Hi,

I try to compile LLVM and the GCC frontend for LLVM.

The steps that I follow are first to compile LLVM and later to compile
GCC front end.

I tried to compile LLVM 1.8, 1.9 releases and the CVS versions.
I tried to compile with different GCC compilers 3.4.0, 4.1.2 and 4.2.0

GCC compilers 3.4.0 and 4.2.0 fail compiling LLVM sources. GCC 4.1.2 works.

I cannot compile GCC front end. When I compile GCC front end with gcc
3.4.0 and gcc 4.1.2 I get some compilation errors (I didn't note
them). When I compile it with gcc4.2.0 I get an error that cc1
requires libstdc++.so.6 GLIBCXX_3.4.9 version

Are the installation instruction up-to-date in the packages? Please,
may you give me the correct combinations of tools that give me
successfully compiled and linked binary set.

Thanks,
Ferad

--
Ferad Zyulkyarov
Barcelona Supercomputing Center
_______________________________________________
LLVM Developers mailing list
[hidden email]         http://llvm.cs.uiuc.edu
http://lists.cs.uiuc.edu/mailman/listinfo/llvmdev
Reply | Threaded
Open this post in threaded view
|

Re: Compilation problems

Reid Spencer-2
Hi Ferad,

On Sat, 2007-03-24 at 15:33 +0100, Ferad Zyulkyarov wrote:

> Hi,
>
> I try to compile LLVM and the GCC frontend for LLVM.
>
> The steps that I follow are first to compile LLVM and later to compile
> GCC front end.
>
> I tried to compile LLVM 1.8, 1.9 releases and the CVS versions.
> I tried to compile with different GCC compilers 3.4.0, 4.1.2 and 4.2.0
>
> GCC compilers 3.4.0 and 4.2.0 fail compiling LLVM sources. GCC 4.1.2 works.
>
> I cannot compile GCC front end. When I compile GCC front end with gcc
> 3.4.0 and gcc 4.1.2 I get some compilation errors (I didn't note
> them). When I compile it with gcc4.2.0 I get an error that cc1
> requires libstdc++.so.6 GLIBCXX_3.4.9 version
>
> Are the installation instruction up-to-date in the packages? Please,
> may you give me the correct combinations of tools that give me
> successfully compiled and linked binary set.

Everything is as up-to-date as far as we know. Have you read the
GettingStarted guide? It is available here:

For 1.8: http://llvm.org/releases/1.8/docs/GettingStarted.html
For 1.9: http://llvm.org/releases/1.9/docs/GettingStarted.html 
For CVS: http://llvm.org/docs/GettingStarted.html
>
> Thanks,
> Ferad
>

_______________________________________________
LLVM Developers mailing list
[hidden email]         http://llvm.cs.uiuc.edu
http://lists.cs.uiuc.edu/mailman/listinfo/llvmdev
Reply | Threaded
Open this post in threaded view
|

Re: Compilation problems

Lauro Ramos Venancio
In reply to this post by Ferad Zyulkyarov
> I cannot compile GCC front end. When I compile GCC front end with gcc
> 3.4.0 and gcc 4.1.2 I get some compilation errors (I didn't note
> them). When I compile it with gcc4.2.0 I get an error that cc1
> requires libstdc++.so.6 GLIBCXX_3.4.9 version
>
Try to configure gcc frontend with --disable-shared.

Lauro
_______________________________________________
LLVM Developers mailing list
[hidden email]         http://llvm.cs.uiuc.edu
http://lists.cs.uiuc.edu/mailman/listinfo/llvmdev
Reply | Threaded
Open this post in threaded view
|

Re: Compilation problems

Chris Lattner
In reply to this post by Ferad Zyulkyarov
On Sat, 24 Mar 2007, Ferad Zyulkyarov wrote:
> I try to compile LLVM and the GCC frontend for LLVM.
> The steps that I follow are first to compile LLVM and later to compile
> GCC front end.
>
> I tried to compile LLVM 1.8, 1.9 releases and the CVS versions.
> I tried to compile with different GCC compilers 3.4.0, 4.1.2 and 4.2.0

In addition to what others have said, be *absolutely* sure that you match
the llvm-gcc version with the llvm version.  They are version locked.

-Chris

> GCC compilers 3.4.0 and 4.2.0 fail compiling LLVM sources. GCC 4.1.2 works.
>
> I cannot compile GCC front end. When I compile GCC front end with gcc
> 3.4.0 and gcc 4.1.2 I get some compilation errors (I didn't note
> them). When I compile it with gcc4.2.0 I get an error that cc1
> requires libstdc++.so.6 GLIBCXX_3.4.9 version
>
> Are the installation instruction up-to-date in the packages? Please,
> may you give me the correct combinations of tools that give me
> successfully compiled and linked binary set.
>
> Thanks,
> Ferad
>
>

-Chris

--
http://nondot.org/sabre/
http://llvm.org/
_______________________________________________
LLVM Developers mailing list
[hidden email]         http://llvm.cs.uiuc.edu
http://lists.cs.uiuc.edu/mailman/listinfo/llvmdev